GitHub Advisoryadvisory · Packagist

GHSA-g84x-g96g-rcjc Librenms has a reflected XSS on error alert

MEDIUM Published 2025-01-16 Modified 2025-03-25 Official page ↗
Aliases
CVE-2025-23201
Ecosystem
Packagist
Packages
librenms/librenms
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2025-01-16

Affected packages

• Packagist librenms/librenms: < 24.11.0 → fixed in 24.11.0

Description

XSS on the parameters:`/addhost` -> param: community of Librenms versions 24.10.1 (https://github.com/librenms/librenms) allows remote attackers to inject malicious scripts. When a user views or interacts with the page displaying the data, the malicious script executes immediately, leading to potential unauthorized actions or data exposure. Proof of Concept: 1. Navigate to the /addhost path. 2. Fill in all required fields. 3. In the Community field, enter the following payload: `">`. 4. Submit the form to save changes. 5 The script will execute when the error alert "No reply with community + payload" appears. Impact: Execution of Malicious Code

Related

Alias · CVE (1)

  • CVE-2025-23201 librenms is a community-based GPL-licensed network monitoring system. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References