GitHub Advisoryadvisory · RubyGems
GHSA-g857-hhfv-j68w Buffer Overflow in Zlib::GzipReader ungetc via large input leads to memory corruption
MEDIUM
Official page ↗
- Aliases
- CVE-2026-27820
- Ecosystem
- RubyGems
- Packages
- zlib
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-120
- Reviewed
- 2026-04-16
Affected packages
• RubyGems zlib: >= 3.2.0, < 3.2.3 → fixed in 3.2.3
• RubyGems zlib: >= 3.1.0, < 3.1.2 → fixed in 3.1.2
• RubyGems zlib: < 3.0.1 → fixed in 3.0.1
Description
Details
A buffer overflow vulnerability exists in `Zlib::GzipReader`.
The `zstream_buffer_ungets` function prepends caller-provided bytes ahead of previously produced output but fails to guarantee the backing Ruby string has enough capacity before the memmove shifts the existing data. This can lead to memory corruption when the buffer length exceeds capacity.
Recommended action
We recommend to update the `zlib` gem to version 3.2.3 or later. In order to ensure compatibility with bundled version in older Ruby series, you may update as follows instead:
• For Ruby 3.2 users: Update to zlib 3.0.1
• For Ruby 3.3 users: Update to zlib 3.1.2
You can use gem update zlib to update it. If you are using bundler, please add `gem "zlib", ">= 3.2.3"` to your Gemfile.
Affected versions
zlib gem 3.2.2 or lower
Credits
calysteon
References
• https://hackerone.com/reports/3467067
Related
Alias · CVE (1)
- CVE-2026-27820 zlib is a Ruby interface for the zlib compression/decompression library. vulnerability
Weakness · CWE (1)
- CWE-120 Buffer Copy without Checking Size of Input weakness
References
- https://github.com/ruby/zlib/security/advisories/GHSA-g857-hhfv-j68w web
- https://nvd.nist.gov/vuln/detail/CVE-2026-27820 advisory
- https://hackerone.com/reports/3467067 web
- https://github.com/ruby/zlib package
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/zlib/CVE-2026-27820.yml web
- https://www.ruby-lang.org/en/news/2026/03/05/buffer-overflow-zlib-cve-2026-27820 web