GitHub Advisoryadvisory · RubyGems

GHSA-g89m-3wjw-h857 Puppet vulnerable to Path Traversal

LOW Published 2017-10-24 Modified 2023-05-12 Official page ↗
Aliases
CVE-2012-3865
Ecosystem
RubyGems
Packages
puppet
Severity
Low
Weaknesses
CWE-22
Reviewed
2020-06-16

Affected packages

• RubyGems puppet: < 2.6.17 → fixed in 2.6.17 • RubyGems puppet: >= 2.7.0, < 2.7.18 → fixed in 2.7.18

Description

Directory traversal vulnerability in `lib/puppet/reports/store.rb` in Puppet before 2.6.17 and 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, when Delete is enabled in auth.conf, allows remote authenticated users to delete arbitrary files on the puppet master server via a `..` (dot dot) in a node name.

Related

Alias · CVE (1)

  • CVE-2012-3865 Directory traversal vulnerability in lib/puppet/reports/store.rb in Puppet before 2.6.17 and 2.7.x before 2.7.18, and Puppet Enterprise… vulnerability

Weakness · CWE (1)

  • CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness

References