GitHub Advisoryadvisory · crates.io

GHSA-g8jh-vg5j-4h3f Apollo Router Improperly Enforces Renamed Access Control Directives

HIGH Published 2025-11-06 Modified 2025-11-07 Official page ↗
Aliases
CVE-2025-64347
Ecosystem
crates.io
Packages
apollo-router
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-284
Reviewed
2025-11-06

Affected packages

• crates.io apollo-router: < 1.61.12 → fixed in 1.61.12 • crates.io apollo-router: >= 2.0.0-alpha.0, < 2.8.1 → fixed in 2.8.1

Description

Summary A vulnerability in Apollo Router allowed for unauthorized access to protected data through schema elements with access control directives (`@authenticated`, `@requiresScopes`, and `@policy`) that were renamed via `@link` imports. Router did not enforce renamed access control directives on schema elements (e.g. fields and types), allowing queries to bypass those element-level access controls. Details Apollo Federation allows users to specify access control directives (`@authenticated`, `@requiresScopes`, and `@policy`](https://www.apollographql.com/docs/graphos/routing/security/authorization#authorization-directives)) to protect schema data access at the element level. These directives can optionally be renamed via the `imports` argument to the `@link` directive, which can be useful if their default names match an existing user-defined directive in their subgraph schema. However, Apollo Router's access control logic ignored the `imports` argument, and would accordingly ignore access control directives that were renamed in this way. Who Is Impacted This vulnerability impacts Apollo Router customers defining `@authenticated`, `@requiresScopes`, or `@policy` directives on schema elements that were renamed via `@link` imports are impacted. Scope of Impact The vulnerability could allow a malicious actor to craft a query that can bypass access control requirements on schema elements protected by renamed access control directives. Patches This vulnerability has been fixed in Apollo Router by updating the access control logic to handle the `imports` argument in `@link` directives. You will need to update Router to one of the following versions: • 1.61.12+ • 2.8.1+ Workarounds • If you are not immediately updating Router to a patched version, you should remove any renames of access control directives in the `imports` argument to the `@link` directive. • Customers not using Apollo Router with renamed access control directives (`@authenticated`, `@requiresScopes`, and `@policy`) are not affected and do not need to take action.

Related

Alias · CVE (1)

  • CVE-2025-64347 Apollo Router Core is a configurable Rust graph router written to run a federated supergraph using Apollo Federation 2. vulnerability

Weakness · CWE (1)

  • CWE-284 Improper Access Control weakness

References