GitHub Advisoryadvisory · Packagist
GHSA-g8pg-33v4-9r96 Thelia authentication bypass vulnerability
HIGH
Official page ↗
- Ecosystem
- Packagist
- Packages
- thelia/thelia
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-287
- Reviewed
- 2024-05-30
Affected packages
• Packagist thelia/thelia: >= 2.0.0-beta1, < 2.1.3 → fixed in 2.1.3
Description
An authentication bypass was identifed in thelia/thelia project for customer and admin. This vulnerability is present from version 2.0.0-beta1 and is fixed in 2.1.3 and 2.2.0-alpha1.
Related
Weakness · CWE (1)
- CWE-287 Improper Authentication weakness
References
- https://github.com/github/advisory-database/pull/8012 web
- https://github.com/thelia/thelia/commit/028cfcf507cd8685772e156ec0c860034d407094 web
- https://github.com/thelia/thelia/commit/71c1cee66d8f2e515e82478f792879fa63843644 web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/thelia/thelia/2015-04-13-1.yaml web
- https://github.com/thelia/thelia package
- https://web.archive.org/web/20160502224630/http://thelia.net/version-2-1-3-with-security-fix web