GitHub Advisoryadvisory · Packagist

GHSA-g8v9-c8m3-942v Remote code execution in php-heic-to-jpg

HIGH Published 2024-10-24 Modified 2024-12-19 Official page ↗
Aliases
CVE-2024-48514
Ecosystem
Packagist
Packages
maestroerror/php-heic-to-jpg
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-94
Reviewed
2024-10-24

Affected packages

• Packagist maestroerror/php-heic-to-jpg: < 1.0.5 → fixed in 1.0.5

Description

php-heic-to-jpg < 1.0.5 is vulnerable to remote code execution. An attacker who can upload heic images is able to execute code on the remote server via the file name. As a result, the CIA is no longer guaranteed. This affects php-heic-to-jpg below 1.0.5.

Related

Alias · CVE (1)

  • CVE-2024-48514 php-heic-to-jpg <= 1.0.5 is vulnerable to code injection (fixed in 1.0.6). vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References