GitHub Advisoryadvisory · npm

GHSA-g8xp-qx39-9jq9 OpenClaw: Incomplete host-env-security-policy allows untrusted model to substitute compiler binaries via env overrides

HIGH Published 2026-04-03 Modified 2026-05-06 Official page ↗
Aliases
CVE-2026-41373
Ecosystem
npm
Packages
openclaw
Severity
High
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N
Weaknesses
CWE-427
Reviewed
2026-04-03

Affected packages

• npm openclaw: < 2026.3.31 → fixed in 2026.3.31

Description

Summary Incomplete `host-env-security-policy.json` allows untrusted model to substitute compiler binaries (`CC`, `CXX`, `CARGO_BUILD_RUSTC`, `CMAKE_C_COMPILER`) via env overrides on approved host exec requests Current Maintainer Triage • Status: narrow • Normalized severity: medium • Assessment: Shipped v2026.3.28 host-env policy missed compiler override vars, but exploitation still requires an approved host-exec request inside the existing exec trust domain, so medium not high. Affected Packages / Versions • Package: `openclaw` (npm) • Latest published npm version: `2026.3.31` • Vulnerable version range: `= 2026.3.31` • First stable tag containing the fix: `v2026.3.31` Fix Commit(s) • `e277a37f896b5011a1df06e6490c6630074d0afa` — 2026-03-30T20:06:32+01:00 OpenClaw thanks @tdjackey for reporting.

Related

Alias · CVE (1)

  • CVE-2026-41373 OpenClaw before 2026.3.31 contains an incomplete host-env-security-policy.json that fails to restrict compiler binary environment… vulnerability

Weakness · CWE (1)

  • CWE-427 Uncontrolled Search Path Element weakness

References