GitHub Advisoryadvisory · PyPI

GHSA-g99h-56mw-8263 LLama-Index CLI OS command injection vulnerability

HIGH Published 2025-05-28 Modified 2025-05-28 Official page ↗
Aliases
CVE-2025-1753
Ecosystem
PyPI
Packages
llama-index-cli
Severity
High
CVSS vector
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-78
Reviewed
2025-05-28

Affected packages

• PyPI llama-index-cli: < 0.4.1 → fixed in 0.4.1

Description

LLama-Index CLI prior to v0.4.1, corresponding to LLama-Index prior to v0.12.21, contains an OS command injection vulnerability. The vulnerability arises from the improper handling of the `--files` argument, which is directly passed into `os.system`. An attacker who controls the content of this argument can inject and execute arbitrary shell commands. This vulnerability can be exploited locally if the attacker has control over the CLI arguments, and remotely if a web application calls the LLama-Index CLI with a user-controlled filename. This issue can lead to arbitrary code execution on the affected system.

Related

Alias · CVE (1)

  • CVE-2025-1753 LLama-Index CLI version v0.12.20 contains an OS command injection vulnerability. vulnerability

Weakness · CWE (1)

  • CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness

References