GitHub Advisoryadvisory · Maven

GHSA-g9cv-v3v4-3h8r Apache Pulsar Incorrect Authorization vulnerability

CRITICAL Published 2023-07-12 Modified 2023-07-12 Official page ↗
Aliases
CVE-2023-30429
Ecosystem
Maven
Packages
org.apache.pulsar:pulsar
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N
Weaknesses
CWE-863
Reviewed
2023-07-12

Affected packages

• Maven org.apache.pulsar:pulsar: < 2.10.4 → fixed in 2.10.4 • Maven org.apache.pulsar:pulsar: >= 2.11.0, < 2.11.1 → fixed in 2.11.1

Description

Incorrect Authorization vulnerability in Apache Software Foundation Apache Pulsar. This issue affects Apache Pulsar: before 2.10.4, and 2.11.0. When a client connects to the Pulsar Function Worker via the Pulsar Proxy where the Pulsar Proxy uses mTLS authentication to authenticate with the Pulsar Function Worker, the Pulsar Function Worker incorrectly performs authorization by using the Proxy's role for authorization instead of the client's role, which can lead to privilege escalation, especially if the proxy is configured with a superuser role. The recommended mitigation for impacted users is to upgrade the Pulsar Function Worker to a patched version. 2.10 Pulsar Function Worker users should upgrade to at least 2.10.4. 2.11 Pulsar Function Worker users should upgrade to at least 2.11.1. 3.0 Pulsar Function Worker users are unaffected. Any users running the Pulsar Function Worker for 2.9.* and earlier should upgrade to one of the above patched versions.

Related

Alias · CVE (1)

  • CVE-2023-30429 Incorrect Authorization vulnerability in Apache Software Foundation Apache Pulsar. vulnerability

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References