GitHub Advisoryadvisory · Maven

GHSA-g9fw-9x87-rmrj Privilege Context Switching Error in Elasticsearch

LOW Published 2021-03-18 Modified 2022-06-06 Official page ↗
Aliases
CVE-2020-7020
Ecosystem
Maven
Packages
org.elasticsearch:elasticsearch
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-269, CWE-270
Reviewed
2021-03-16

Affected packages

• Maven org.elasticsearch:elasticsearch: < 6.8.13 → fixed in 6.8.13 • Maven org.elasticsearch:elasticsearch: >= 7.0.0, < 7.9.2 → fixed in 7.9.2

Description

Elasticsearch versions before 6.8.13 and 7.9.2 contain a document disclosure flaw when Document or Field Level Security is used. Search queries do not properly preserve security permissions when executing certain complex queries. This could result in the search disclosing the existence of documents the attacker should not be able to view. This could result in an attacker gaining additional insight into potentially sensitive indices.

Related

Alias · CVE (1)

  • CVE-2020-7020 Elasticsearch versions before 6.8.13 and 7.9.2 contain a document disclosure flaw when Document or Field Level Security is used. vulnerability

Weakness · CWE (2)

  • CWE-269 Improper Privilege Management weakness
  • CWE-270 Privilege Context Switching Error weakness

References