GitHub Advisoryadvisory · Maven
GHSA-g9hg-x9c9-7xgr XXE vulnerability in Jenkins CVS Plugin
HIGH
Official page ↗
- Aliases
- CVE-2020-2324
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:cvs
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-611
- Reviewed
- 2022-12-16
Affected packages
• Maven org.jenkins-ci.plugins:cvs: < 2.17 → fixed in 2.17
Description
Jenkins CVS Plugin 2.16 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.
This allows attackers able to control an agent process to have Jenkins parse a crafted changelog file that uses external entities for extraction of secrets from the Jenkins controller or server-side request forgery.
Jenkins CVS Plugin 2.17 disables external entity resolution for its XML parser.
Related
Alias · CVE (1)
- CVE-2020-2324 Jenkins CVS Plugin 2.16 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks. vulnerability
Weakness · CWE (1)
- CWE-611 Improper Restriction of XML External Entity Reference weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-2324 advisory
- https://github.com/jenkinsci/cvs-plugin/commit/ff121443b282c8dbd6a5ee4841f152f78e4a5954 web
- https://github.com/jenkinsci/cvs-plugin package
- https://www.jenkins.io/security/advisory/2020-12-03/#SECURITY-2146 web
- http://www.openwall.com/lists/oss-security/2020/12/03/2 web