GitHub Advisoryadvisory · Packagist
GHSA-g9w4-m5fx-x3wv Yoast Duplicate Post has an Authenticated (Contributor+) Missing Authorization to Arbitrary Post Duplication and Overwrite
MEDIUM
Official page ↗
- Aliases
- CVE-2026-1217
- Ecosystem
- Packagist
- Packages
- yoast/duplicate-post
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-862
- Reviewed
- 2026-03-19
Affected packages
• Packagist yoast/duplicate-post: < 4.6 → fixed in 4.6
Description
The Yoast Duplicate Post plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the clone_bulk_action_handler() and republish_request() functions in all versions up to, and including, 4.5. This makes it possible for authenticated attackers, with Contributor-level access and above, to duplicate any post on the site including private, draft, and trashed posts they shouldn't have access to. Additionally, attackers with Author-level access and above can use the Rewrite & Republish feature to overwrite any published post with their own content.
Related
Alias · CVE (1)
- CVE-2026-1217 The Yoast Duplicate Post plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the… vulnerability
Weakness · CWE (1)
- CWE-862 Missing Authorization weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2026-1217 advisory
- https://github.com/Yoast-dist/duplicate-post package
- https://plugins.trac.wordpress.org/browser/duplicate-post/tags/4.5/src/handlers/bulk-handler.php#L115 web
- https://plugins.trac.wordpress.org/browser/duplicate-post/tags/4.5/src/post-republisher.php#L128 web
- https://www.wordfence.com/threat-intel/vulnerabilities/id/05f175e6-08a9-4199-948c-5bd8b3caaa39?source=cve web