GitHub Advisoryadvisory · npm

GHSA-gc34-5v43-h7v8 nuxt Code Injection vulnerability

CRITICAL Published 2023-06-13 Modified 2024-11-18 Official page ↗
Aliases
CVE-2023-3224
Ecosystem
npm
Packages
nuxt
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-94
Reviewed
2023-06-21

Affected packages

• npm nuxt: >= 3.4.0, < 3.4.3 → fixed in 3.4.3

Description

he Nuxt dev server between versions 3.4.0 and 3.4.3 is vulnerable to code injection when it is exposed publicly.

Related

Alias · CVE (1)

  • CVE-2023-3224 Code Injection in GitHub repository nuxt/nuxt prior to 3.5.3. vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References