GitHub Advisoryadvisory · Maven

GHSA-gchq-9r68-6jwv Cross-Site Request Forgery in Jenkins Credentials Plugin

MEDIUM Published 2021-06-16 Modified 2023-10-27 Official page ↗
Aliases
CVE-2021-21648
Ecosystem
Maven
Packages
org.jenkins-ci.plugins:credentials
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2021-05-19

Affected packages

• Maven org.jenkins-ci.plugins:credentials: >= 2.3.16, < 2.3.19 → fixed in 2.3.19 • Maven org.jenkins-ci.plugins:credentials: >= 2.3.15, < 2.3.15.1 → fixed in 2.3.15.1 • Maven org.jenkins-ci.plugins:credentials: >= 2.3.14, < 2.3.14.1 → fixed in 2.3.14.1 • Maven org.jenkins-ci.plugins:credentials: >= 2.3.8, < 2.3.13.1 → fixed in 2.3.13.1 • Maven org.jenkins-ci.plugins:credentials: >= 2.3.1, < 2.3.7.1 → fixed in 2.3.7.1 • Maven org.jenkins-ci.plugins:credentials: < 2.3.0.1 → fixed in 2.3.0.1

Description

Jenkins Credentials Plugin prior to 2.3.19, 2.3.15.1, 2.3.14.1, 2.3.13.1, 2.3.7.1, and 2.3.0.1 does not escape user-controlled information on a view it provides, resulting in a reflected cross-site scripting (XSS) vulnerability. Jenkins Credentials Plugin 2.3.19, 2.3.15.1, 2.3.14.1, 2.3.13.1, 2.3.7.1, and 2.3.0.1 restricts the user-controlled information it provides to a safe subset.

Related

Alias · CVE (1)

  • CVE-2021-21648 Jenkins Credentials Plugin 2.3.18 and earlier does not escape user-controlled information on a view it provides, resulting in a reflected… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References