GitHub Advisoryadvisory · PyPI
GHSA-gcjf-29m9-888q PaddlePaddle vulnerable to Code Injection
CRITICAL
Official page ↗
- Aliases
- CVE-2022-46742
- Ecosystem
- PyPI
- Packages
- paddlepaddle
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
- Reviewed
- 2022-12-07
Affected packages
• PyPI paddlepaddle: < 2.4.0 → fixed in 2.4.0
Description
Code injection in `paddle.audio.functional.get_window` in PaddlePaddle 2.4.0-rc0 allows arbitrary code execution. A patch is available on the `develop` branch of the repository and anticipated to be part of a 2.4 release.
Related
Alias · CVE (1)
- CVE-2022-46742 Code injection in paddle.audio.functional.get_window in PaddlePaddle 2.4.0-rc0 allows arbitrary code execution. vulnerability
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-46742 advisory
- https://github.com/PaddlePaddle/Paddle/pull/47386 web
- https://github.com/PaddlePaddle/Paddle/commit/26c419ca386aeae3c461faf2b828d00b48e908eb web
- https://github.com/PaddlePaddle/Paddle package
- https://github.com/PaddlePaddle/Paddle/blob/develop/security/advisory/pdsa-2022-002.md web
- https://github.com/pypa/advisory-database/tree/main/vulns/paddlepaddle/PYSEC-2022-43063.yaml web