GitHub Advisoryadvisory · PyPI

GHSA-gcr6-rf47-jrgf Loaded Databook of Tablib prone to python insertion resulting in command execution

CRITICAL Published 2018-07-13 Modified 2024-10-27 Official page ↗
Aliases
CVE-2017-2810
Ecosystem
PyPI
Packages
tablib
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Reviewed
2020-06-16

Affected packages

• PyPI tablib: < 0.11.5 → fixed in 0.11.5

Description

An exploitable vulnerability exists in the Databook loading functionality of Tablib 0.11.4. A yaml loaded Databook can execute arbitrary python commands resulting in command execution. An attacker can insert python into loaded yaml to trigger this vulnerability.

Related

Alias · CVE (1)

  • CVE-2017-2810 An exploitable vulnerability exists in the Databook loading functionality of Tablib 0.11.4. vulnerability

References