GitHub Advisoryadvisory · PyPI

GHSA-gfr2-qpxh-qj9m Path Traversal in Ansible

MEDIUM Published 2021-04-07 Modified 2024-09-09 Official page ↗
Aliases
CVE-2020-1735
Ecosystem
PyPI
Packages
ansible
Severity
Moderate
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N
Weaknesses
CWE-22
Reviewed
2021-04-05

Affected packages

• PyPI ansible: >= 2.7.0a1, < 2.7.18 → fixed in 2.7.18 • PyPI ansible: >= 2.8.0a1, < 2.8.12 → fixed in 2.8.12 • PyPI ansible: >= 2.9.0a1, < 2.9.8 → fixed in 2.9.8

Description

A flaw was found in the Ansible Engine when the fetch module is used. An attacker could intercept the module, inject a new path, and then choose a new destination path on the controller node. All versions in 2.7.x, 2.8.x and 2.9.x branches are believed to be vulnerable.

Related

Alias · CVE (1)

  • CVE-2020-1735 A flaw was found in the Ansible Engine when the fetch module is used. vulnerability

Weakness · CWE (1)

  • CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness

References