GitHub Advisoryadvisory · Maven
GHSA-gfv5-grx2-9jw2 Improper Privilege Management in Elasticsearch
HIGH
Official page ↗
- Aliases
- CVE-2020-7009
- Ecosystem
- Maven
- Packages
- org.elasticsearch:elasticsearch
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-266, CWE-269
- Reviewed
- 2022-06-23
Affected packages
• Maven org.elasticsearch:elasticsearch: >= 6.7.0, < 6.8.8 → fixed in 6.8.8
• Maven org.elasticsearch:elasticsearch: >= 7.0.0, < 7.6.2 → fixed in 7.6.2
Description
Elasticsearch versions from 6.7.0 to 6.8.7 and 7.0.0 to 7.6.1 contain a privilege escalation flaw if an attacker is able to create API keys. An attacker who is able to generate an API key can perform a series of steps that result in an API key being generated with elevated privileges.
Related
Alias · CVE (1)
- CVE-2020-7009 Elasticsearch versions from 6.7.0 before 6.8.8 and 7.0.0 before 7.6.2 contain a privilege escalation flaw if an attacker is able to create… vulnerability