GitHub Advisoryadvisory · Packagist

GHSA-gg36-9346-9qx9 phpMyAdmin Remote Code Execution

HIGH Published 2022-05-17 Modified 2023-08-29 Official page ↗
Aliases
CVE-2013-3239
Ecosystem
Packagist
Packages
phpmyadmin/phpmyadmin
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
Weaknesses
CWE-94
Reviewed
2023-08-29

Affected packages

• Packagist phpmyadmin/phpmyadmin: >= 3.5.0, < 3.5.8.1 → fixed in 3.5.8.1

Description

phpMyAdmin 3.5.x before 3.5.8 and 4.x before 4.0.0-rc3, when a SaveDir directory is configured, allows remote authenticated users to execute arbitrary code by using a double extension in the filename of an export file, leading to interpretation of this file as an executable file by the Apache HTTP Server, as demonstrated by a .php.sql filename.

Related

Alias · CVE (1)

  • CVE-2013-3239 phpMyAdmin 3.5.x before 3.5.8 and 4.x before 4.0.0-rc3, when a SaveDir directory is configured, allows remote authenticated users to… vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References