GitHub Advisoryadvisory · npm, Packagist, NuGet

GHSA-gg8r-xjwq-4w92 Cross-site scripting vulnerability in TinyMCE alerts

MEDIUM Published 2022-12-08 Modified 2022-12-12 Official page ↗
Aliases
CVE-2022-23494
Ecosystem
npm, Packagist, NuGet
Packages
tinymce, tinymce/tinymce, TinyMCE
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2022-12-08

Affected packages

• npm tinymce: >= 6.0.0, < 6.3.1 → fixed in 6.3.1 • Packagist tinymce/tinymce: >= 6.0.0, < 6.3.1 → fixed in 6.3.1 • NuGet TinyMCE: >= 6.0.0, < 6.3.1 → fixed in 6.3.1 • npm tinymce: < 5.10.7 → fixed in 5.10.7 • Packagist tinymce/tinymce: < 5.10.7 → fixed in 5.10.7 • NuGet TinyMCE: < 5.10.7 → fixed in 5.10.7

Description

Impact A cross-site scripting (XSS) vulnerability was discovered in the alert and confirm dialogs when these dialogs were provided with malicious HTML content. This can occur in plugins that use the alert or confirm dialogs, such as in the `image` plugin, which presents these dialogs when certain errors occur. The vulnerability allowed arbitrary JavaScript execution when an alert presented in the TinyMCE UI for the current user. Patches This vulnerability has been patched in TinyMCE 5.10.7 and TinyMCE 6.3.1 by ensuring HTML sanitization was still performed after unwrapping invalid elements. Fix To avoid this vulnerability: • Upgrade to TinyMCE 5.10.7 or higher for TinyMCE 5.x. • Upgrade to TinyMCE 6.3.1 or higher for TinyMCE 6.x. Workaround To reduce the impact of this vulnerability: • Ensure the the `images_upload_handler` returns a valid value as per the images_upload_handler documentation. References • https://www.tiny.cloud/docs/release-notes/release-notes5107/#securityfixes • https://www.tiny.cloud/docs/tinymce/6/6.3-release-notes/#security-fixes For more information If you have any questions or comments about this advisory: • Email us at [email protected] • Open an issue in the TinyMCE repo

Related

Alias · CVE (1)

  • CVE-2022-23494 tinymce is an open source rich text editor. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References