GitHub Advisoryadvisory · npm

GHSA-gg9v-mgcp-v6m7 OpenClaw: Unbound bootstrap setup codes allow privilege escalation during pairing

HIGH Published 2026-04-03 Modified 2026-05-06 Official page ↗
Aliases
CVE-2026-41386
Ecosystem
npm
Packages
openclaw
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-269, CWE-648
Reviewed
2026-04-03

Affected packages

• npm openclaw: < 2026.3.22 → fixed in 2026.3.22

Description

Summary Bootstrap setup codes were not bound to the intended device role and scopes, allowing first-use privilege escalation during pairing. Current Maintainer Triage • Status: open • Normalized severity: high • Assessment: Real first-use bootstrap privilege-escalation bug fixed and shipped in v2026.3.22+, so keep open for publication with current severity. Affected Packages / Versions • Package: `openclaw` (npm) • Latest published npm version: `2026.3.31` • Vulnerable version range: `= 2026.3.22` • First stable tag containing the fix: `v2026.3.22` Fix Commit(s) • `a600c72ed7d0045a27f58bf031d2b36ecb0141c9` — 2026-03-22T23:57:15-07:00 OpenClaw thanks @tdjackey for reporting.

Related

Alias · CVE (1)

  • CVE-2026-41386 OpenClaw before 2026.3.22 contains a privilege escalation vulnerability where bootstrap setup codes are not bound to intended device roles… vulnerability

Weakness · CWE (2)

  • CWE-269 Improper Privilege Management weakness
  • CWE-648 Incorrect Use of Privileged APIs weakness

References