GitHub Advisoryadvisory · Maven
GHSA-gghc-g8cj-4vfv Stored XSS vulnerability in Jenkins Git Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2021-21684
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:git
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-116, CWE-79
- Reviewed
- 2022-12-15
Affected packages
• Maven org.jenkins-ci.plugins:git: < 4.8.3 → fixed in 4.8.3
Description
Jenkins Git Plugin 4.8.2 and earlier does not escape the Git SHA-1 checksum parameters provided to commit notifications when displaying them in a build cause.
This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to submit crafted commit notifications to the `/git/notifyCommit` endpoint.
Jenkins Git Plugin 4.8.3 rejects Git SHA-1 checksum parameters that do not match the expected format. Existing values are sanitized when displayed on the UI.
This vulnerability is only exploitable in Jenkins 2.314 and earlier, LTS 2.303.1 and earlier. See the LTS upgrade guide.
Related
Alias · CVE (1)
- CVE-2021-21684 Jenkins Git Plugin 4.8.2 and earlier does not escape the Git SHA-1 checksum parameters provided to commit notifications when displaying… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-21684 advisory
- https://github.com/jenkinsci/git-plugin/commit/5474cc942bfba60927be629ff47fb41c38c66741 web
- https://github.com/jenkinsci/git-plugin package
- https://www.jenkins.io/security/advisory/2021-10-06/#SECURITY-2499 web
- http://www.openwall.com/lists/oss-security/2021/10/06/1 web