GitHub Advisoryadvisory · Maven
GHSA-ggmp-fxfg-277r Apache Struts RCE Vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2016-3090
- Ecosystem
- Maven
- Packages
- org.apache.struts:struts2-parent
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2023-07-31
Affected packages
• Maven org.apache.struts:struts2-parent: >= 2.0.0, < 2.3.20 → fixed in 2.3.20
Description
The `TextParseUtil.translateVariables` method in Apache Struts 2.x before 2.3.20 allows remote attackers to execute arbitrary code via a crafted OGNL expression with ANTLR tooling.
Related
Alias · CVE (1)
- CVE-2016-3090 The TextParseUtil.translateVariables method in Apache Struts 2.x before 2.3.20 allows remote attackers to execute arbitrary code via a… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2016-3090 advisory
- https://github.com/apache/struts package
- https://security.netapp.com/advisory/ntap-20180629-0005 web
- https://struts.apache.org/docs/s2-027.html web
- https://web.archive.org/web/20210123095942/http://www.securityfocus.com/bid/85131 web
- https://web.archive.org/web/20211206100940/https://www.securitytracker.com/id/1035267 web