GitHub Advisoryadvisory · PyPI
GHSA-ggmv-6q9p-9gm6 Cross-site Scripting in django-unicorn
MEDIUM
Official page ↗
- Aliases
- CVE-2021-42134
- Ecosystem
- PyPI
- Packages
- django-unicorn
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2021-10-12
Affected packages
• PyPI django-unicorn: < 0.36.1 → fixed in 0.36.1
Description
The Unicorn framework before 0.36.1 for Django allows XSS via a component. NOTE: this issue exists because of an incomplete fix for CVE-2021-42053.
Related
Alias · CVE (1)
- CVE-2021-42134 The Unicorn framework before 0.36.1 for Django allows XSS via a component. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-42134 advisory
- https://github.com/adamghill/django-unicorn/commit/3a832a9e3f6455ddd3b87f646247269918ad10c6 web
- https://github.com/adamghill/django-unicorn package
- https://github.com/adamghill/django-unicorn/compare/0.36.0...0.36.1 web
- https://github.com/advisories/GHSA-ggmv-6q9p-9gm6 advisory
- https://github.com/pypa/advisory-database/tree/main/vulns/django-unicorn/PYSEC-2021-369.yaml web