GitHub Advisoryadvisory · RubyGems
GHSA-gh9q-2xrm-x6qv CGI has Denial of Service (DoS) potential in Cookie.parse
MEDIUM
Official page ↗
- Aliases
- CVE-2025-27219
- Ecosystem
- RubyGems
- Packages
- cgi
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:L
- Weaknesses
- CWE-400, CWE-770
- Reviewed
- 2025-03-03
Affected packages
• RubyGems cgi: < 0.3.5.1 → fixed in 0.3.5.1
• RubyGems cgi: >= 0.3.6, < 0.3.7 → fixed in 0.3.7
• RubyGems cgi: >= 0.4.0, < 0.4.2 → fixed in 0.4.2
Description
There is a possibility for DoS by in the cgi gem.
This vulnerability has been assigned the CVE identifier CVE-2025-27219. We recommend upgrading the cgi gem.
Details
CGI::Cookie.parse took super-linear time to parse a cookie string in some cases. Feeding a maliciously crafted cookie string into the method could lead to a Denial of Service.
Please update CGI gem to version 0.3.5.1, 0.3.7, 0.4.2 or later.
Affected versions
cgi gem versions <= 0.3.5, 0.3.6, 0.4.0 and 0.4.1.
Credits
Thanks to lio346 for discovering this issue.
Also thanks to mame for fixing this vulnerability.
Related
Alias · CVE (1)
- CVE-2025-27219 In the CGI gem before 0.4.2 for Ruby, the CGI::Cookie.parse method in the CGI library contains a potential Denial of Service (DoS)… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-27219 advisory
- https://github.com/ruby/cgi/pull/52 web
- https://github.com/ruby/cgi/pull/53 web
- https://github.com/ruby/cgi/pull/54 web
- https://hackerone.com/reports/2936778 web
- https://github.com/ruby/cgi package
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/cgi/CVE-2025-27219.yml web
- https://lists.debian.org/debian-lts-announce/2025/03/msg00008.html web
- https://www.cve.org/CVERecord?id=CVE-2025-27219 web