GitHub Advisoryadvisory · Packagist

GHSA-ghc5-95c2-vwcv Auth0 Symfony SDK has Insufficient Entropy in Cookie Encryption

HIGH Published 2026-04-03 Modified 2026-04-03 Official page ↗
Ecosystem
Packagist
Packages
auth0/symfony
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N
Weaknesses
CWE-331
Reviewed
2026-04-03

Affected packages

• Packagist auth0/symfony: >= 5.0.0, < 5.8.0 → fixed in 5.8.0

Description

Impact In applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies. Am I Affected? Consumers are affected if their application meets the following preconditions: • It uses the Auth0 Symfony SDK, versions between 5.0.0 and 5.7.0 • Auth0 Symfony SDK using the Auth0-PHP SDK versions between 8.0.0 to 8.18.0. Resolution Upgrade Auth0/symfony-auth0 to version 5.8.0 or greater.

Related

Weakness · CWE (1)

  • CWE-331 Insufficient Entropy weakness

References