GitHub Advisoryadvisory · Go

GHSA-ghx2-6v4g-9wmm usememos/memos makes Incorrect Use of Privileged APIs

HIGH Published 2022-12-28 Modified 2023-01-10 Official page ↗
Aliases
CVE-2022-4796
Ecosystem
Go
Packages
github.com/usememos/memos
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
Weaknesses
CWE-648
Reviewed
2022-12-30

Affected packages

• Go github.com/usememos/memos: < 0.9.1 → fixed in 0.9.1

Description

In usememos/memos 0.9.0 and prior, a user with login permission can delete all notes of the whole application via `API DELETE https://demo.usememos.com/api/memo/$idnote`. The vulnerability will lose all user notes data throughout the system, causing damage to user data.

Related

Alias · CVE (1)

  • CVE-2022-4796 Incorrect Use of Privileged APIs in GitHub repository usememos/memos prior to 0.9.1. vulnerability

Weakness · CWE (1)

  • CWE-648 Incorrect Use of Privileged APIs weakness

References