GitHub Advisoryadvisory · Maven
GHSA-gj5m-m88j-v7c3 Apache ActiveMQ's default configuration doesn't secure the API web context
HIGH
Official page ↗
- Aliases
- CVE-2024-32114
- Ecosystem
- Maven
- Packages
- org.apache.activemq:apache-activemq
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-1188
- Reviewed
- 2024-05-03
Affected packages
• Maven org.apache.activemq:apache-activemq: >= 6.0.0, < 6.1.2 → fixed in 6.1.2
Description
In Apache ActiveMQ 6.x, the default configuration doesn't secure the API web context (where the Jolokia JMX REST API and the Message REST API are located). It means that anyone can use these layers without any required authentication. Potentially, anyone can interact with the broker (using Jolokia JMX REST API) and/or produce/consume messages or purge/delete destinations (using the Message REST API).
To mitigate, users can update the default conf/jetty.xml configuration file to add authentication requirement:
Or we encourage users to upgrade to Apache ActiveMQ 6.1.2 where the default configuration has been updated with authentication by default.
Related
Alias · CVE (1)
- CVE-2024-32114 In Apache ActiveMQ 6.x, the default configuration doesn't secure the API web context (where the Jolokia JMX REST API and the Message REST… vulnerability
Weakness · CWE (1)
- CWE-1188 Initialization of a Resource with an Insecure Default weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-32114 advisory
- https://github.com/apache/activemq/pull/1201 web
- https://github.com/apache/activemq/commit/43cc596219b6a8c8b5a54fbda3fb68cb4424f2d0 web
- https://activemq.apache.org/security-advisories.data/CVE-2024-32114-announcement.txt web
- https://github.com/apache/activemq package
- https://issues.apache.org/jira/browse/AMQ-9477 web