GitHub Advisoryadvisory · NuGet

GHSA-gjf6-3w4p-7xfh Microsoft Security Advisory CVE-2025-21176 | .NET and Visual Studio Remote Code Execution Vulnerability

HIGH Published 2025-01-14 Modified 2025-05-06 Official page ↗
Aliases
CVE-2025-21176
Ecosystem
NuGet
Packages
Microsoft.NetCore.App.Runtime.linux-arm, Microsoft.NetCore.App.Runtime.linux-arm64, Microsoft.NetCore.App.Runtime.linux-musl-arm, Microsoft.NetCore.App.Runtime.linux-musl-arm64, Microsoft.NetCore.App.Runtime.linux-musl-x64, Microsoft.NetCore.App.Runtime.linux-x64, Microsoft.NetCore.App.Runtime.osx-arm64, Microsoft.NetCore.App.Runtime.osx-x64, Microsoft.NetCore.App.Runtime.win-arm, Microsoft.NetCore.App.Runtime.win-arm64, Microsoft.NetCore.App.Runtime.win-x64, Microsoft.NetCore.App.Runtime.win-x86
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-126
Reviewed
2025-01-14

Affected packages

• NuGet Microsoft.NetCore.App.Runtime.linux-arm: >= 9.0.0, < 9.0.1 → fixed in 9.0.1 • NuGet Microsoft.NetCore.App.Runtime.linux-arm64: >= 9.0.0, < 9.0.1 → fixed in 9.0.1 • NuGet Microsoft.NetCore.App.Runtime.linux-musl-arm: >= 9.0.0, < 9.0.1 → fixed in 9.0.1 • NuGet Microsoft.NetCore.App.Runtime.linux-musl-arm64: >= 9.0.0, < 9.0.1 → fixed in 9.0.1 • NuGet Microsoft.NetCore.App.Runtime.linux-musl-x64: >= 9.0.0, < 9.0.1 → fixed in 9.0.1 • NuGet Microsoft.NetCore.App.Runtime.linux-x64: >= 9.0.0, < 9.0.1 → fixed in 9.0.1 • NuGet Microsoft.NetCore.App.Runtime.osx-arm64: >= 9.0.0, < 9.0.1 → fixed in 9.0.1 • NuGet Microsoft.NetCore.App.Runtime.osx-x64: >= 9.0.0, < 9.0.1 → fixed in 9.0.1 • NuGet Microsoft.NetCore.App.Runtime.win-arm: >= 9.0.0, < 9.0.1 → fixed in 9.0.1 • NuGet Microsoft.NetCore.App.Runtime.win-arm64: >= 9.0.0, < 9.0.1 → fixed in 9.0.1 • NuGet Microsoft.NetCore.App.Runtime.win-x64: >= 9.0.0, < 9.0.1 → fixed in 9.0.1 • NuGet Microsoft.NetCore.App.Runtime.win-x86: >= 9.0.0, < 9.0.1 → fixed in 9.0.1 • NuGet Microsoft.NetCore.App.Runtime.linux-arm: >= 8.0.0, < 8.0.12 → fixed in 8.0.12 • NuGet Microsoft.NetCore.App.Runtime.linux-arm64: >= 8.0.0, < 8.0.12 → fixed in 8.0.12 • NuGet Microsoft.NetCore.App.Runtime.linux-musl-arm: >= 8.0.0, < 8.0.12 → fixed in 8.0.12 • NuGet Microsoft.NetCore.App.Runtime.linux-musl-arm64: >= 8.0.0, < 8.0.12 → fixed in 8.0.12 • NuGet Microsoft.NetCore.App.Runtime.linux-musl-x64: >= 8.0.0, < 8.0.12 → fixed in 8.0.12 • NuGet Microsoft.NetCore.App.Runtime.linux-x64: >= 8.0.0, < 8.0.12 → fixed in 8.0.12 • NuGet Microsoft.NetCore.App.Runtime.osx-arm64: >= 8.0.0, < 8.0.12 → fixed in 8.0.12 • NuGet Microsoft.NetCore.App.Runtime.osx-x64: >= 8.0.0, < 8.0.12 → fixed in 8.0.12 • NuGet Microsoft.NetCore.App.Runtime.win-arm: >= 8.0.0, < 8.0.12 → fixed in 8.0.12 • NuGet Microsoft.NetCore.App.Runtime.win-arm64: >= 8.0.0, < 8.0.12 → fixed in 8.0.12 • NuGet Microsoft.NetCore.App.Runtime.win-x64: >= 8.0.0, < 8.0.12 → fixed in 8.0.12 • NuGet Microsoft.NetCore.App.Runtime.win-x86: >= 8.0.0, < 8.0.12 → fixed in 8.0.12

Description

Microsoft Security Advisory CVE-2025-21176 | .NET and Visual Studio Remote Code Execution Vulnerability Executive summary Microsoft is releasing this security advisory to provide information about a vulnerability in .NET 8.0 and .NET 9.0. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. An attacker could exploit this vulnerability by loading a specially crafted file in Visual Studio. Announcement Announcement for this issue can be found at https://github.com/dotnet/runtime/issues/111425 Mitigation factors Microsoft has not identified any mitigating factors for this vulnerability. Affected software • Any .NET 8.0 application running on .NET 8.0.11 or earlier. • Any .NET 9.0 application running on .NET 9.0.0 or earlier. Affected Packages The vulnerability affects any Microsoft .NET project if it uses any of affected packages versions listed below .NET 9 Package name | Affected version | Patched version ------------ | ---------------- | ------------------------- Microsoft.NetCore.App.Runtime.linux-arm | >= 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, .NET 8 Package name | Affected version | Patched version ------------ | ---------------- | ------------------------- Microsoft.NetCore.App.Runtime.linux-arm | >= 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, How do I know if I am affected? If you have a runtime or SDK with a version listed, or an affected package listed in affected software or affected packages, you're exposed to the vulnerability. How do I fix the issue? 1. To fix the issue please install the latest version of .NET 9.0 or .NET 8.0, as appropriate. If you have installed one or more .NET SDKs through Visual Studio, Visual Studio will prompt you to update Visual Studio, which will also update your .NET SDKs. 2. If your application references the vulnerable package, update the package reference to the patched version. • You can list the versions you have installed by running the `dotnet --info` command. You will see output like the following; ``` .NET SDK: Version: 9.0.100 Commit: 59db016f11 Workload version: 9.0.100-manifests.3068a692 MSBuild version: 17.12.7+5b8665660 Runtime Environment: OS Name: Mac OS X OS Version: 15.2 OS Platform: Darwin RID: osx-arm64 Base Path: /usr/local/share/dotnet/sdk/9.0.100/ .NET workloads installed: There are no installed workloads to display. Configured to use loose manifests when installing new manifests. Host: Version: 9.0.0 Architecture: arm64 Commit: 9d5a6a9aa4 .NET SDKs installed: 9.0.100 [/usr/local/share/dotnet/sdk] .NET runtimes installed: Microsoft.AspNetCore.App 9.0.0 [/usr/local/share/dotnet/shared/Microsoft.AspNetCore.App] Microsoft.NETCore.App 9.0.0 [/usr/local/share/dotnet/shared/Microsoft.NETCore.App] Other architectures found: x64 [/usr/local/share/dotnet] registered at [/etc/dotnet/install_location_x64] Environment variables: Not set global.json file: Not found Learn more: https://aka.ms/dotnet/info Download .NET: https://aka.ms/dotnet/download ``` • If you're using .NET 9.0, you should download and install .NET 9.0 Runtime or .NET 9.0.100 SDK (for Visual Studio 2022 v17.12 latest Preview) from https://dotnet.microsoft.com/download/dotnet-core/9.0. Once you have installed the updated runtime or SDK, restart your apps for the update to take effect. Additionally, if you've deployed self-contained applications targeting any of the impacted versions, these applications are also vulnerable and must be recompiled and redeployed. Other Information Reporting Security Issues If you have found a potential security issue in .NET 9.0 or .NET 8.0, please email details to [email protected]. Reports may qualify for the Microsoft .NET Core & .NET 5 Bounty. Details of the Microsoft .NET Bounty Program including terms and conditions are at . Support You can ask questions about this issue on GitHub in the .NET GitH…

Related

Alias · CVE (1)

  • CVE-2025-21176 .NET, .NET Framework, and Visual Studio Remote Code Execution Vulnerability vulnerability

Weakness · CWE (1)

  • CWE-126 Buffer Over-read weakness

References