GitHub Advisoryadvisory · npm
GHSA-gjx9-wg9x-7gvp Flowise Vulnerable to SQL Injection via `tableName` Parameter
HIGH
Official page ↗
- Aliases
- CVE-2025-29189
- Ecosystem
- npm
- Packages
- flowise-components
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:L
- Weaknesses
- CWE-89
- Reviewed
- 2025-04-10
Affected packages
• npm flowise-components: < 2.2.4 → fixed in 2.2.4
Description
Flowise <= 2.2.3 is vulnerable to SQL Injection. via tableName parameter at Postgres_VectorStores.
Related
Alias · CVE (1)
- CVE-2025-29189 Flowise <= 2.2.3 is vulnerable to SQL Injection. vulnerability
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-29189 advisory
- https://github.com/FlowiseAI/Flowise/pull/3818 web
- https://github.com/FlowiseAI/Flowise/commit/9a417bdc95f58d6dd92cbf60dad42414aba34754 web
- https://drive.google.com/file/d/1WHPslTmQmAM9xPJifULS2qAo7hcidB4L/view?usp=sharing web
- https://github.com/FlowiseAI/Flowise package