GitHub Advisoryadvisory · RubyGems

GHSA-gjxw-5w2q-7grf Rails activerecord gem has Improper Input Validation vulnerability

MEDIUM Published 2017-10-24 Modified 2023-05-26 Official page ↗
Aliases
CVE-2010-3933
Ecosystem
RubyGems
Packages
activerecord
Severity
Moderate
Weaknesses
CWE-20
Reviewed
2020-06-16

Affected packages

• RubyGems activerecord: >= 2.3.9, < 2.3.10 → fixed in 2.3.10 • RubyGems activerecord: >= 3.0.0, < 3.0.1 → fixed in 3.0.1

Description

Ruby on Rails 2.3.9 and 3.0.0 does not properly handle nested attributes, which allows remote attackers to modify arbitrary records by changing the names of parameters for form inputs.

Related

Alias · CVE (1)

  • CVE-2010-3933 Ruby on Rails 2.3.9 and 3.0.0 does not properly handle nested attributes, which allows remote attackers to modify arbitrary records by… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References