GitHub Advisoryadvisory · Packagist

GHSA-gmx8-8rff-qv6q phpBB's Smiley Pack acp_icons.php main pack vulnerable to cross site scripting

MEDIUM Published 2023-11-02 Modified 2024-10-30 Official page ↗
Aliases
CVE-2023-5917
Ecosystem
Packagist
Packages
phpbb/phpbb
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-10-30

Affected packages

• Packagist phpbb/phpbb: < 3.3.11 → fixed in 3.3.11

Description

A vulnerability, which was classified as problematic, has been found in phpBB up to 3.3.10. This issue affects the function main of the file `phpBB/includes/acp/acp_icons.php` of the component Smiley Pack Handler. The manipulation of the argument pack leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 3.3.11 is able to address this issue. The patch is named ccf6e6c255d38692d72fcb613b113e6eaa240aac. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-244307.

Related

Alias · CVE (1)

  • CVE-2023-5917 A vulnerability, which was classified as problematic, has been found in phpBB up to 3.3.10. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References