GitHub Advisoryadvisory · Packagist

GHSA-gphj-63h8-r9vq Moodle directory traversal vulnerability

MEDIUM Published 2022-05-13 Modified 2024-01-25 Official page ↗
Aliases
CVE-2015-1493
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Weaknesses
CWE-22
Reviewed
2024-01-25

Affected packages

• Packagist moodle/moodle: < 2.6.8 → fixed in 2.6.8 • Packagist moodle/moodle: >= 2.7.0, < 2.7.5 → fixed in 2.7.5 • Packagist moodle/moodle: >= 2.8.0, < 2.8.3 → fixed in 2.8.3

Description

Directory traversal vulnerability in the min_get_slash_argument function in lib/configonlylib.php in Moodle through 2.5.9, 2.6.x before 2.6.8, 2.7.x before 2.7.5, and 2.8.x before 2.8.3 allows remote authenticated users to read arbitrary files via a .. (dot dot) in the file parameter, as demonstrated by reading PHP scripts.

Related

Alias · CVE (1)

  • CVE-2015-1493 Directory traversal vulnerability in the min_get_slash_argument function in lib/configonlylib.php in Moodle through 2.5.9, 2.6.x before… vulnerability

Weakness · CWE (1)

  • CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness

References