GitHub Advisoryadvisory · PyPI
GHSA-gppg-gqw8-wh9g litellm vulnerable to remote code execution based on using eval unsafely
CRITICAL
Official page ↗
- Aliases
- CVE-2024-5751
- Ecosystem
- PyPI
- Packages
- litellm
- Severity
- Critical
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
- Reviewed
- 2024-06-28
Affected packages
• PyPI litellm: < 1.40.16 → fixed in 1.40.16
Description
BerriAI/litellm version v1.35.8 contains a vulnerability where an attacker can achieve remote code execution. The vulnerability exists in the `add_deployment` function, which decodes and decrypts environment variables from base64 and assigns them to `os.environ`. An attacker can exploit this by sending a malicious payload to the `/config/update` endpoint, which is then processed and executed by the server when the `get_secret` function is triggered. This requires the server to use Google KMS and a database to store a model.
Related
Alias · CVE (1)
- CVE-2024-5751 BerriAI/litellm version v1.35.8 contains a vulnerability where an attacker can achieve remote code execution. vulnerability
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness