GitHub Advisoryadvisory · RubyGems

GHSA-gppp-5xc5-wfpx Active Record allows bypassing of database-query restrictions

MEDIUM Published 2017-10-24 Modified 2023-08-25 Official page ↗
Aliases
CVE-2013-0155
Ecosystem
RubyGems
Packages
activerecord
Severity
Moderate
Weaknesses
CWE-284
Reviewed
2020-06-16

Affected packages

• RubyGems activerecord: >= 3.0.0, < 3.0.19 → fixed in 3.0.19 • RubyGems activerecord: >= 3.1.0, < 3.1.10 → fixed in 3.1.10 • RubyGems activerecord: >= 3.2.0, < 3.2.11 → fixed in 3.2.11

Description

Ruby on Rails 3.0.x before 3.0.19, 3.1.x before 3.1.10, and 3.2.x before 3.2.11 does not properly consider differences in parameter handling between the Active Record component and the JSON implementation, which allows remote attackers to bypass intended database-query restrictions and perform NULL checks or trigger missing WHERE clauses via a crafted request, as demonstrated by certain "[nil]" values, a related issue to CVE-2012-2660 and CVE-2012-2694.

Related

Alias · CVE (1)

  • CVE-2013-0155 Ruby on Rails 3.0.x before 3.0.19, 3.1.x before 3.1.10, and 3.2.x before 3.2.11 does not properly consider differences in parameter… vulnerability

Weakness · CWE (1)

  • CWE-284 Improper Access Control weakness

References