GitHub Advisoryadvisory · PyPI

GHSA-gprj-xvq8-w53q Apache Airflow has an Improper Authorization issue

LOW Published 2026-06-01 Modified 2026-07-09 Official page ↗
Aliases
CVE-2026-40963
Ecosystem
PyPI
Packages
apache-airflow
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-285
Reviewed
2026-07-09

Affected packages

• PyPI apache-airflow: >= 3.0.0, < 3.2.2 → fixed in 3.2.2

Description

The structure_data endpoint in the Airflow UI returned external dependency graph nodes for linked Dags without checking whether the caller had read permission on those linked Dags. An authenticated UI/API user authorized for one Dag could enumerate linked Dag IDs and dependency metadata for other Dags they were not authorized to read. Affects deployments that rely on per-Dag read scoping to keep Dag dependency topology private across teams. Users are advised to upgrade to `apache-airflow` 3.2.2 or later.

Related

Alias · CVE (1)

  • CVE-2026-40963 The structure_data endpoint in the Airflow UI returned external dependency graph nodes for linked Dags without checking whether the caller… vulnerability

Weakness · CWE (1)

  • CWE-285 Improper Authorization weakness

References