GitHub Advisoryadvisory · npm

GHSA-gpvr-g6gh-9mc2 No Charset in Content-Type Header in express

MEDIUM Published 2018-10-23 Modified 2021-08-02 Official page ↗
Aliases
CVE-2014-6393
Ecosystem
npm
Packages
express
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2020-06-16

Affected packages

• npm express: < 3.11.0 → fixed in 3.11.0 • npm express: >= 4.0.0, < 4.5.0 → fixed in 4.5.0

Description

Vulnerable versions of express do not specify a charset field in the content-type header while displaying 400 level response messages. The lack of enforcing user's browser to set correct charset, could be leveraged by an attacker to perform a cross-site scripting attack, using non-standard encodings, like UTF-7. Recommendation For express 3.x, update express to version 3.11 or later. For express 4.x, update express to version 4.5 or later.

Related

Alias · CVE (1)

  • CVE-2014-6393 The Express web framework before 3.11 and 4.x before 4.5 for Node.js does not provide a charset field in HTTP Content-Type headers in 400… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References