GitHub Advisoryadvisory · Maven

GHSA-gq28-h5vg-8prx Privilege escalation in spring security

HIGH Published 2021-05-10 Modified 2021-08-31 Official page ↗
Aliases
CVE-2021-22112
Ecosystem
Maven
Packages
org.springframework.security:spring-security-bom, org.springframework.security:spring-security-web
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-269
Reviewed
2021-03-31

Affected packages

• Maven org.springframework.security:spring-security-bom: >= 5.4.0, < 5.4.4 → fixed in 5.4.4 • Maven org.springframework.security:spring-security-bom: >= 5.3.0, < 5.3.8 → fixed in 5.3.8 • Maven org.springframework.security:spring-security-bom: < 5.2.9 → fixed in 5.2.9 • Maven org.springframework.security:spring-security-web: >= 5.4.0, < 5.4.4 → fixed in 5.4.4 • Maven org.springframework.security:spring-security-web: >= 5.3.0, < 5.3.8 → fixed in 5.3.8 • Maven org.springframework.security:spring-security-web: < 5.2.9 → fixed in 5.2.9

Description

Spring Security 5.4.x prior to 5.4.4, 5.3.x prior to 5.3.8.RELEASE, 5.2.x prior to 5.2.9.RELEASE, and older unsupported versions can fail to save the SecurityContext if it is changed more than once in a single request.A malicious user cannot cause the bug to happen (it must be programmed in). However, if the application's intent is to only allow the user to run with elevated privileges in a small portion of the application, the bug can be leveraged to extend those privileges to the rest of the application.

Related

Alias · CVE (1)

  • CVE-2021-22112 Spring Security 5.4.x prior to 5.4.4, 5.3.x prior to 5.3.8.RELEASE, 5.2.x prior to 5.2.9.RELEASE, and older unsupported versions can fail… vulnerability

Weakness · CWE (1)

  • CWE-269 Improper Privilege Management weakness

References