GitHub Advisoryadvisory · Go
GHSA-gq3r-5833-5532 Mattermost Fails to Validate File Paths
MEDIUM
Official page ↗
- Aliases
- CVE-2025-36530
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost-server, github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server/v5, github.com/mattermost/mattermost-server/v6
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N
- Weaknesses
- CWE-22
- Reviewed
- 2025-08-21
Affected packages
• Go github.com/mattermost/mattermost-server: >= 10.9.0, < 10.9.2 → fixed in 10.9.2
• Go github.com/mattermost/mattermost-server: >= 10.8.0, < 10.8.4 → fixed in 10.8.4
• Go github.com/mattermost/mattermost-server: >= 10.5.0, < 10.5.9 → fixed in 10.5.9
• Go github.com/mattermost/mattermost-server: >= 9.11.0, < 9.11.18 → fixed in 9.11.18
• Go github.com/mattermost/mattermost/server/v8: < 8.0.0-20250619095651-9dd0b3943e55 → fixed in 8.0.0-20250619095651-9dd0b3943e55
• Go github.com/mattermost/mattermost-server/v5: <= 5.11.1 (no fix yet)
• Go github.com/mattermost/mattermost-server/v6: <= 6.7.2 (no fix yet)
Description
Mattermost versions 10.9.x <= 10.9.1, 10.8.x <= 10.8.3, 10.5.x <= 10.5.8, 9.11.x <= 9.11.17 fail to properly validate file paths during plugin import operations which allows restricted admin users to install unauthorized custom plugins via path traversal in the import functionality, bypassing plugin signature enforcement and marketplace restrictions.
Related
Alias · CVE (1)
- CVE-2025-36530 Mattermost versions 10.9.x <= 10.9.1, 10.8.x <= 10.8.3, 10.5.x <= 10.5.8, 9.11.x <= 9.11.17 fail to properly validate file paths during… vulnerability
Weakness · CWE (1)
- CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness