GitHub Advisoryadvisory · Go

GHSA-gqf8-rvrh-g7w6 Rancher cloud credentials can be used through proxy API by users without access

CRITICAL Published 2026-03-03 Modified 2026-03-03 Official page ↗
Aliases
CVE-2021-25320
Ecosystem
Go
Packages
github.com/rancher/rancher
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Weaknesses
CWE-284
Reviewed
2026-03-03

Affected packages

• Go github.com/rancher/rancher: >= 2.2.0, < 2.4.16 → fixed in 2.4.16 • Go github.com/rancher/rancher: >= 2.5.0, < 2.5.9 → fixed in 2.5.9

Description

A vulnerability was discovered in Rancher 2.2.0 through the aforementioned patched versions, where cloud credentials weren't being properly validated through the Rancher API. Specifically through a proxy designed to communicate with cloud providers. Any Rancher user that was logged-in and aware of a cloud-credential ID that was valid for a given cloud provider, could call that cloud provider's API through the proxy API, and the cloud-credential would be attached. The exploit is limited to valid Rancher users. There is not a direct mitigation outside of upgrading to the patched Rancher versions.

Related

Alias · CVE (1)

  • CVE-2021-25320 A Improper Access Control vulnerability in Rancher, allows users in the cluster to make request to cloud providers by creating requests… vulnerability

Weakness · CWE (1)

  • CWE-284 Improper Access Control weakness

References