GitHub Advisoryadvisory · Maven

GHSA-gqhm-4h93-rrhg Jenkins Script Security and Pipeline Groovy Plugins Sandbox Bypass

HIGH Published 2022-05-13 Modified 2024-01-09 Official page ↗
Aliases
CVE-2018-1000866
Ecosystem
Maven
Packages
org.jenkins-ci.plugins.workflow:workflow-cps, org.jenkins-ci.plugins:script-security
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-269
Reviewed
2024-01-09

Affected packages

• Maven org.jenkins-ci.plugins.workflow:workflow-cps: < 2.60 → fixed in 2.60 • Maven org.jenkins-ci.plugins:script-security: < 1.48 → fixed in 1.48

Description

A sandbox bypass vulnerability exists in Pipeline: Groovy Plugin 2.59 and earlier in groovy-sandbox/src/main/java/org/kohsuke/groovy/sandbox/SandboxTransformer.java, groovy-cps/lib/src/main/java/com/cloudbees/groovy/cps/SandboxCpsTransformer.java that allows attackers with Job/Configure permission, or unauthorized attackers with SCM commit privileges and corresponding pipelines based on Jenkinsfiles set up in Jenkins, to execute arbitrary code on the Jenkins master JVM

Related

Alias · CVE (1)

  • CVE-2018-1000866 A sandbox bypass vulnerability exists in Pipeline: Groovy Plugin 2.59 and earlier in… vulnerability

Weakness · CWE (1)

  • CWE-269 Improper Privilege Management weakness

References