GitHub Advisoryadvisory · Packagist
GHSA-gqrp-qhv8-phrv Moodle Cross-site Scripting
MEDIUM
Official page ↗
- Aliases
- CVE-2018-14631
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-04-24
Affected packages
• Packagist moodle/moodle: >= 3.3, < 3.3.8 → fixed in 3.3.8
• Packagist moodle/moodle: >= 3.4, < 3.4.5 → fixed in 3.4.5
• Packagist moodle/moodle: >= 3.5, < 3.5.2 → fixed in 3.5.2
Description
moodle before versions 3.5.2, 3.4.5, 3.3.8 is vulnerable to a boost theme - blog search GET parameter insufficiently filtered. The breadcrumb navigation provided by Boost theme when displaying search results of a blog were insufficiently filtered, which could result in reflected XSS if a user followed a malicious link containing JavaScript in the search parameter.
Related
Alias · CVE (1)
- CVE-2018-14631 moodle before versions 3.5.2, 3.4.5, 3.3.8 is vulnerable to a boost theme - blog search GET parameter insufficiently filtered. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-14631 advisory
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-14631 web
- https://github.com/moodle/moodle package
- https://moodle.org/mod/forum/discuss.php?d=376025 web
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-62857 web
- http://www.securityfocus.com/bid/105371 web