GitHub Advisoryadvisory · Maven
GHSA-grmg-5q49-mqmf Jenkins Crowd 2 Integration Plugin server-side request forgery vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2018-1000422
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:crowd2
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-918
- Reviewed
- 2024-01-09
Affected packages
• Maven org.jenkins-ci.plugins:crowd2: < 2.0.1 → fixed in 2.0.1
Description
An improper authorization vulnerability exists in Jenkins Crowd 2 Integration Plugin 2.0.0 and earlier in CrowdSecurityRealm.java that allows attackers to have Jenkins perform a connection test, connecting to an attacker-specified server with attacker-specified credentials and connection settings.
Related
Alias · CVE (1)
- CVE-2018-1000422 An improper authorization vulnerability exists in Jenkins Crowd 2 Integration Plugin 2.0.0 and earlier in CrowdSecurityRealm.java that… vulnerability
Weakness · CWE (1)
- CWE-918 Server-Side Request Forgery weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000422 advisory
- https://github.com/jenkinsci/crowd2-plugin/commit/a93d0fa221454adb4087520d8c1c087828211598 web
- https://github.com/jenkinsci/crowd2-plugin package
- https://jenkins.io/security/advisory/2018-09-25/#SECURITY-1067 web
- https://web.archive.org/web/20200227092927/http://www.securityfocus.com/bid/106532 web