GitHub Advisoryadvisory · Packagist

GHSA-grvw-qq2j-r898 Moodle multiple cross-site scripting (XSS) vulnerabilities

MEDIUM Published 2022-05-13 Modified 2024-01-26 Official page ↗
Aliases
CVE-2015-5336
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-01-26

Affected packages

• Packagist moodle/moodle: < 2.7.11 → fixed in 2.7.11 • Packagist moodle/moodle: >= 2.8.0, < 2.8.9 → fixed in 2.8.9 • Packagist moodle/moodle: >= 2.9.0, < 2.9.3 → fixed in 2.9.3

Description

Multiple cross-site scripting (XSS) vulnerabilities in the survey module in Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 allow remote authenticated users to inject arbitrary web script or HTML by leveraging the student role and entering a crafted survey answer.

Related

Alias · CVE (1)

  • CVE-2015-5336 Multiple cross-site scripting (XSS) vulnerabilities in the survey module in Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9,… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References