GitHub Advisoryadvisory · Maven

GHSA-gv5f-cjw9-5vxg Camel-xstream component in Apache Camel can allow remote attackers to execute arbitrary commands

CRITICAL Published 2018-10-16 Modified 2023-12-19 Official page ↗
Aliases
CVE-2015-5344
Ecosystem
Maven
Packages
org.apache.camel:camel-xstream
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Reviewed
2020-06-16

Affected packages

• Maven org.apache.camel:camel-xstream: < 2.15.5 → fixed in 2.15.5 • Maven org.apache.camel:camel-xstream: >= 2.16.0, < 2.16.1 → fixed in 2.16.1

Description

The camel-xstream component in Apache Camel before 2.15.5 and 2.16.x before 2.16.1 allow remote attackers to execute arbitrary commands via a crafted serialized Java object in an HTTP request.

Related

Alias · CVE (1)

  • CVE-2015-5344 The camel-xstream component in Apache Camel before 2.15.5 and 2.16.x before 2.16.1 allow remote attackers to execute arbitrary commands via… vulnerability

References