GitHub Advisoryadvisory · Packagist
GHSA-gv8f-43pg-c5qw Moodle Improper Input Validation vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2021-36402
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-20
- Reviewed
- 2023-03-08
Affected packages
• Packagist moodle/moodle: >= 3.11.0-beta, < 3.11.1 → fixed in 3.11.1
• Packagist moodle/moodle: >= 3.10.0-beta, < 3.10.5 → fixed in 3.10.5
• Packagist moodle/moodle: < 3.9.8 → fixed in 3.9.8
Description
In affected versions of Moodle, users' names require additional sanitizing in the account confirmation email, to prevent a self-registration phishing risk. This issue has been patched in versions 3.9.8, 3.10.5 and 3.11.1.
Related
Alias · CVE (1)
- CVE-2021-36402 In Moodle, Users' names required additional sanitizing in the account confirmation email, to prevent a self-registration phishing risk. vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness