GitHub Advisoryadvisory · PyPI

GHSA-gv98-g628-m9x5 Django Cross-site Scripting Vulnerability

MEDIUM Published 2022-05-17 Modified 2024-09-18 Official page ↗
Aliases
CVE-2015-0220
Ecosystem
PyPI
Packages
Django
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2023-08-03

Affected packages

• PyPI Django: < 1.4.18 → fixed in 1.4.18 • PyPI Django: >= 1.6, < 1.6.10 → fixed in 1.6.10 • PyPI Django: >= 1.7, < 1.7.3 → fixed in 1.7.3

Description

The `django.util.http.is_safe_url` function in Django before 1.4.18, 1.6.x before 1.6.10, and 1.7.x before 1.7.3 does not properly handle leading whitespaces, which allows remote attackers to conduct cross-site scripting (XSS) attacks via a crafted URL, related to redirect URLs, as demonstrated by a `\njavascript:` URL.

Related

Alias · CVE (1)

  • CVE-2015-0220 The django.util.http.is_safe_url function in Django before 1.4.18, 1.6.x before 1.6.10, and 1.7.x before 1.7.3 does not properly handle… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References