GitHub Advisoryadvisory · Packagist
GHSA-gvcw-x64m-pfcj Wallabag cross-site scripting (XSS) vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2018-11352
- Ecosystem
- Packagist
- Packages
- wallabag/wallabag
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-01-10
Affected packages
• Packagist wallabag/wallabag: >= 2.2.3, < 2.3.3 → fixed in 2.3.3
Description
The Wallabag application 2.2.3 to 2.3.2 is affected by one cross-site scripting (XSS) vulnerability that is stored within the configuration page. This vulnerability enables the execution of a JavaScript payload each time an administrator visits the configuration page. The vulnerability can be exploited with authentication and used to target administrators and steal their sessions.
Related
Alias · CVE (1)
- CVE-2018-11352 The Wallabag application 2.2.3 to 2.3.2 is affected by one cross-site scripting (XSS) vulnerability that is stored within the configuration… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness