GitHub Advisoryadvisory · Packagist

GHSA-gvf2-2f4g-jqf4 Drupal core contains a potential PHP Object Injection vulnerability

HIGH Published 2024-12-10 Modified 2025-06-04 Official page ↗
Aliases
CVE-2024-55638
Ecosystem
Packagist
Packages
drupal/core, drupal/core-recommended, drupal/drupal
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-502, CWE-915
Reviewed
2024-12-10

Affected packages

• Packagist drupal/core: >= 8.8.0, < 10.2.11 → fixed in 10.2.11 • Packagist drupal/core: >= 10.3.0, < 10.3.9 → fixed in 10.3.9 • Packagist drupal/core: >= 7.0, < 7.102 → fixed in 7.102 • Packagist drupal/core-recommended: >= 8.8.0, < 10.2.11 → fixed in 10.2.11 • Packagist drupal/core-recommended: >= 10.3.0, < 10.3.9 → fixed in 10.3.9 • Packagist drupal/core-recommended: >= 7.0, < 7.102 → fixed in 7.102 • Packagist drupal/drupal: >= 8.8.0, < 10.2.11 → fixed in 10.2.11 • Packagist drupal/drupal: >= 10.3.0, < 10.3.9 → fixed in 10.3.9 • Packagist drupal/drupal: >= 7.0, < 7.102 → fixed in 7.102

Description

Drupal core contains a potential PHP Object Injection vulnerability that (if combined with another exploit) could lead to Remote Code Execution. It is not directly exploitable. This issue is mitigated by the fact that in order for it to be exploitable, a separate vulnerability must be present to allow an attacker to pass unsafe input to `unserialize()`. There are no such known exploits in Drupal core. To help protect against this potential vulnerability, some additional checks have been added to Drupal core's database code. If you use a third-party database driver, check the release notes for additional configuration steps that may be required in certain cases. This issue affects Drupal Core: from 7.0 before 7.102, from 8.0.0 before 10.2.11, from 10.3.0 before 10.3.9.

Related

Alias · CVE (1)

  • CVE-2024-55638 Deserialization of Untrusted Data vulnerability in Drupal Core allows Object Injection.This issue affects Drupal Core: from 7.0 before… vulnerability

Weakness · CWE (2)

  • CWE-502 Deserialization of Untrusted Data weakness
  • CWE-915 Improperly Controlled Modification of Dynamically-Determined Object Attributes weakness

References