GitHub Advisoryadvisory · Maven

GHSA-gvg3-83q4-rfhq Command injection in Apache Sling

HIGH Published 2023-02-14 Modified 2023-02-22 Official page ↗
Aliases
CVE-2023-25141
Ecosystem
Maven
Packages
org.apache.sling:org.apache.sling.jcr.base
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-74
Reviewed
2023-02-14

Affected packages

• Maven org.apache.sling:org.apache.sling.jcr.base: < 3.1.12 → fixed in 3.1.12

Description

Apache Sling JCR Base < 3.1.12 has a critical injection vulnerability when running on old JDK versions (JDK 1.8.191 or earlier) through utility functions in RepositoryAccessor. The functions getRepository and getRepositoryFromURL allow an application to access data stored in a remote location via JDNI and RMI. Users of Apache Sling JCR Base are recommended to upgrade to Apache Sling JCR Base 3.1.12 or later, or to run on a more recent JDK.

Related

Alias · CVE (1)

  • CVE-2023-25141 Apache Sling JCR Base < 3.1.12 has a critical injection vulnerability when running on old JDK versions (JDK 1.8.191 or earlier) through… vulnerability

Weakness · CWE (1)

  • CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness

References